Issue with iPad Keyboard when connecting to a VMWare VNC session

Comments

3 comments

  • Avatar
    Jump Desktop Support

    Sorry about the delay in getting back to you.

    Looks like VMWare's VNC server is incorrectly mapping keys sent from Jump - or Jump isn't sending the correct set of keys back to VMWare's VNC server.  You might have to edit VMWare's settings to use a vnckeymap file that matches a US English keyboard (I'm not entirely sure about this since I havne't tested this with VMware yet)

    Can you please a look at this VMWare help article: http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1004815

    Try setting it to a US English keyboard layout. 

    0
    Comment actions Permalink
  • Avatar
    Jump Desktop Support

    Update: I just tried this with VMWare Fusion 4.x - unfortunately, setting RemoteDisplay.vnc.keymap="us" in the vmx file did not have any effect. I also tried with the "uk" layout without any luck.

    Also, I think the reason the VMware VNC server works correctly with your Mac's 'Screen Sharing' app is because you actually press the 'Shift' key on your physical keyboard to create the "@" sign which causes 'Screen Sharing' to first send the shift key press and then the @ sign. This is exactly what you're doing in Jump when you manually press the "Shift" button from the menu. I tried this out with a beta version of Jump's new Mac viewer app and it worked correctly because with a physical keyboard Jump knows when you need pressed the 'Shift' key on the keyboard and sends the raw event to VMWare server. 

    0
    Comment actions Permalink
  • Avatar
    Jump Desktop Support

    We just released Jump Desktop 5.0 on the App Store. It has a bunch of fixes related to shifted characters. Can you please give it a shot? 

    0
    Comment actions Permalink

Please sign in to leave a comment.