mouse cursor circle disappears as soon as I lift my finger off the screen

Comments

8 comments

  • Avatar
    Jump Desktop Support

    @Trevor,

    This isn't a known issue on our end.

    One reason this could happen is if you have a USB mouse attached to your Iconia. Jump for Android detects mouse input from physical mice on Android 3.0+ and automatically hides the mouse pointer. You wouldn't happen to have a USB mouse attached to your device?

    Also, where did you get the ICS update for the Iconia? Our test machines are still running 3.2.

    0
    Comment actions Permalink
  • Avatar
    Trevor Your

    I don't have have a mouse attached.  Its weird because the arrow does show up if I tap the screen once.  I it just disappears after I drag it somewhere then take my finger off the screen.

    I was afraid you were going to ask that.  Its a custom ROM from http://forum.tegraowners.com/viewtopic.php?t=106.  Its actually the fastest most stable ROM I can find right now.  Much faster then stock.  I imagine the speed is a result of getting rid of the honeycomb source code.  ICS is much cleaner and therefore quicker.

    I have tried Jump Desktop on a HC 3.2.1 ROM as well and it works fine.  I also tried it on my Galaxy Nexus running ICS 4.0.3 and it also works fine.  It does seem to be an issue with this particular ROM and not ICS in general.  Its just so weird that the issue is so specific.  Everything else in the APP works just fine.  You would think either the app would work or it wouldn't.  I was just hoping you guys had seen this in the past with other versions of Android or other ROMs and knew of a workaround to fix it.  

    My next step is to ask the developer of the ROM if he can fix the issue but I was hoping to get as much information as I could on what the issue might be before emailing him.

    0
    Comment actions Permalink
  • Avatar
    Jump Desktop Support

    Thanks for the link Trevor. 

    I tested this on a stock build of ICS 4.0.3 running on a Galaxy Nexus and couldn't reproduce the problem.

    By looking at our code I can tell you that we only deliberately hide the pointer when we think a touch event is sent by a physical mouse and then we unhide the mouse pointer when we think the touch event is sent by a physical touch from your finger. Incase it helps the ROM developer - this is what we use to check if the input is from a physical mouse: http://developer.android.com/reference/android/view/InputDevice.html#SOURCE_MOUSE

    0
    Comment actions Permalink
  • Avatar
    Keiran

    I have this exact same problem on my Atrix 4g which also happens to be running a custom ICS ROM (See here - http://forum.xda-developers.com/showthread.php?t=1445052). Any insight would be appreciated. 

    0
    Comment actions Permalink
  • Avatar
    Jump Desktop Support

    @Keiran it seems like this is specific to ICS custom ROMs. We're still unsure why this would happen because we haven't investigated this on custom ROM implementations yet. My current _guess_ is Jump maybe confused and thinks a physical mouse is attached to the device on such roms (which is what may cause the pointer to be hidden). Right now we don't have a workaround to disable the hiding behaviour unfortunately. 

    0
    Comment actions Permalink
  • Avatar
    Keiran

    Thanks for the reply. I would note that it does actually (although only in the latest alpha, build 5) work on my Kindle Fire which is also running a custom ICS ROM (http://forum.xda-developers.com/showthread.php?t=1411895). Uncertain if this is useful information for you guys to try to track down the problem, but there you go ;). 

    0
    Comment actions Permalink
  • Avatar
    Keiran

    It doesn't appear I can edit my previous comment. I confused the versions from my Atrix with that of my Kindle Fire. The KF build that works is labeled VideoTouch1-20.zip, prior versions to this did not. 

    0
    Comment actions Permalink
  • Avatar
    Trevor Your

    my issue with my a500 has been resolved by the rom developer.  apparently it was an issue with multitouch.  I believe it was fixed by updating the kernel.  You can check out the forum link in my post.  i posted starting on page 164.  maybe you can contact digetx and ask him for specifics on what he fixed so you can pass the info on to the dev of your rom.

    0
    Comment actions Permalink

Please sign in to leave a comment.