Ubuntu VNC server keyboard mapping problem

Comments

4 comments

  • Avatar
    Jump Desktop Support

    @e2b, I'm having trouble reproducing the issue. I'm attaching a screen shot of my current Ubuntu 11.10 configuration. Can you please let me know if it differs from your config? 

    Thanks.




    Screen Shot 2012-02-12 at 8.36.39 PM.png
  • Avatar
    e2b

    Your configuration looks similar to mine (see attached screenshot). The only difference I see is, that I'm also using German as user and system language. I tested this point and switched both to English while the keyboard layout is still German, but the problem still exists. Also there are no vino-server configuration files that include anything like the language.

    So the only difference is that my system was installed with German used in language and keyboard settings and also the home folder including the gnome profile was initially generated by a German localized system. Currently I have no time to do more tests like installing a test system in English or booting the Ubuntu Live CD. If you want to do this, I recommend dict.cc or dict.leo.org as dictionary.

    I'm still wondering why other VNC clients have no keyboard layout problem when connected to the vino-server. Either they can detect the server and/or server language and change their behavior as a workaround or they use a more reliable way to transmit the typed characters.




    29.png
  • Avatar
    Jump Desktop Support

    @e2b - we've just fixed an issue in the Jump Desktop Android 4.0.5 update released yesterday. Can you please try it out and see if it helps fix the problem?

  • Avatar
    e2b

    Sorry, nothing changed. Keys are still interchanged (Y → Z, Z → Y, etc.).

Please sign in to leave a comment.