Comments

14 comments

  • Official comment
    Avatar
    james joiner

    I know this is a little late, but for anyone else who has the problem connecting a Jump Desktop Client to the Raspberry Pi built-in VNC Server, I was able to get it working by setting Authentication to 'None' in the Option Menu. Here is a screen shot of the change..

    Comment actions Permalink
  • Avatar
    Ian Beyer

    This is a little inaccurate. Raspbian comes with VNC out of the box, and Jump Desktop is unable to connect to it. I think the OP (and I too) would like to know what special settings we need to enable on the RPi to allow Jump Desktop to connect.

     

    2
    Comment actions Permalink
  • Avatar
    Landon Ivy

    That doesn't fix the issue. I can't connect to raspberry pi using jump desktop. Real VNC has a free cloud server option so I can connect via that I guess. Why can't Jump Desktop just make a VNC cloud server app for Raspberry Pi OS?

    2
    Comment actions Permalink
  • Avatar
    .

    Could you expound more "should be able to connect",  a couple of example snapshots would be helpful.  Maybe a setup matrix.

    1
    Comment actions Permalink
  • Avatar
    Jump Desktop Support

    Hi,

    I'm not completely sure what you mean. However, here's a guide to installing a VNC server on a Raspberry Pi: https://learn.adafruit.com/adafruit-raspberry-pi-lesson-7-remote-control-with-vnc/installing-vnc

    1
    Comment actions Permalink
  • Avatar
    WMC

    That's a good idea. I'm a fan of Jump. I just began using Raspbian and our firewall blocks all VNC traffic (not negotiable) so RDP is my only option. Any help?

    0
    Comment actions Permalink
  • Avatar
    Aleksey Senin

    Even if configuration is set to VNC Auth, it doesn’t work. I don’t think this application ( without trial option) should position itself as a best one that works with VNC without any issue. Frankly, I would like to get my money back if there is no solution.
    If application supports specific VNC server implementation it should be specified in documentation or release notes and also configuration steps need to be provided.

    0
    Comment actions Permalink
  • Avatar
    Woodrow Stool

    I can maybe shed a little light on this.  Raspberry Pi and Jump worked fine until the latest update - vncserver that comes with the Rasperry Pi was updated and this broke connectivity with Jump on MacOS- it also broke connectivity with Remmina on Linux.  There's a technical brief posted yesterday that reminds users to use VNC authorization with a new directive to set the vncserver to allow legacy clients to connect - unfortunately there is no option to do this on a Raspberry Pi from the VNC GUI.  It appears that RealVNC (the provider of the Raspberry Pi vncserver) has updated their code and it is no longer compatible with Jump (or Remmina on Linux).  If anyone knows the fix to allow legacy clients to connect to the Raspberry vncserver I'm all ears.

    0
    Comment actions Permalink
  • Avatar
    Jump Desktop Support

    Hi,

    You need to check the ‘Allow connections from legacy VNC viewers’ check box as described here: https://support.jumpdesktop.com/hc/en-us/articles/216424363-VNC-VNC-Server-Error-No-configured-security-type-is-supported-by-3-3-viewer

    0
    Comment actions Permalink
  • Avatar
    Woodrow Stool

    I referenced this in my note - I cannot find anywhere on the Raspberry Pi vncserver GUI to allow for legacy clients to connect - can you take a screenshot and post it here (or on the technical note referenced above) so that we can all see it?  I may be blind, but I don't see where to do that.

    0
    Comment actions Permalink
  • Avatar
    Woodrow Stool

    There is no checkbox for "Allow connections from legacy VNC viewers" in the RealVNC server included in the Raspberry PI OS release dated Feb 21 2023:

     

    0
    Comment actions Permalink
  • Avatar
    Woodrow Stool

    HERE'S THE FIX:  In the above dialog box set Encryption to "Prefer off".  Clear the VNC passwords (by selecting Unix password) and then re-enable VNC password authentication.  When specifying the new password the dialog box will then offer a checkbox for "Allow connections from legacy VNC Viewers".  Check this box, "Apply", and you're back in business.

    Many thanks to Jump Desktop support for pointing this out and thus offering a solution.

    0
    Comment actions Permalink
  • Avatar
    Jump Desktop Support

    Yes - as long as the PI is running a VNC Server, Jump should be able to connect.

    -1
    Comment actions Permalink
  • Avatar
    Jump Desktop Support (Edited )

    You'll need to set the VNC server's 'Authentication Type' to 'VNC Authentication' and set a VNC password. It should work once you do that.

    -2
    Comment actions Permalink

Please sign in to leave a comment.