how to connect to ubuntu 14.04 over vnc ssh tunnel

Comments

9 comments

  • Avatar
    Jump Desktop Support

    Hi Greg,

    Try this:

    1. Create a new connection in Jump by clicking the + icon and select VNC. Set the Address to: 127.0.0.1:5901 and hit Save.

    2. Right click the newly created icon and then click "Edit". Then click "SSH Tunnel". Ccick the drop down and click "Edit SSH Tunnels".

    3. Add a new tunnel with IP address 192.168.2.1. Save your settings and close the preferences window.

    4. Next in the "SSH Tunnel" drop down select your newly create server save you settings.

    Thats it! You should be able to connect.

  • Avatar
    Greg Gilley

    I tried that setup (which is basically the same as what I had tried before). I get the prompt to approve the certificate, but the login still fails. "Please make sure tcp forwarding is enabled on the server. Details: "Channel open failure"

         Greg

     

  • Avatar
    Jump Desktop Support

    Greg, I've revised step #1 above. Specifically - you need to set the 'Host' address to 127.0.0.1:5901 if you haven't already.

  • Avatar
    Greg Gilley

    That worked. Thanks!

         Greg

     

     

  • Avatar
    Adrian M.

    Hello,
    I have the same problem like Greg.
    I want to connect to my Debian-Server via SSH, but I can't. I get the same error message. "Could not create SSH tunnel - Please make sure tcp forwarding is enabled on the server. Details: "Channel open failure""

    I tried with your four steps above, but this didn't work either.

    Do you have any other suggestions for me?

     

    Thanks a lot and greetings from Germany
    Adrian




    Screen Shot 2016-08-26 at 14.12.58.png
  • Avatar
    Jump Desktop Support

    Adrian, check the Host address you have for your connection. Just right click your computer's icon in Jump and then click Edit. Then in the Host address either put in 127.0.0.1:5900 or 127.0.0.1:5900+display number.

    Here's whats happening: Jump was able to successfully connect to the SSH server but the SSH server on the other end wasn't able to create an outgoing connection to the "Host" address you've specified. 

  • Avatar
    Adrian M.

    Thanks for fast reply.
    I tried it, but there was only the loading circle with "Creating tunnel" and after 5 minutes the same message ("Could not create SSH tunnel[...]") again...

    On my local server I made a tunnel with the command: "ssh -L 5900:127.0.0.1:5900 -N -f -l username serverIP" and set in Jump Desktop the Host on "127.0.0.1:5900" and make the usual SSH Tunnel with Host = serverIP and Username = localServerUsername and password... Right?

  • Avatar
    Jump Desktop Support

    Adrian,

    In Jump:

    1. SSH Server settings: Host = serverIP     <--- this is the IP address of the server running the SSH server. Username and password are the SSH username and password

    2. Create a new computer in Jump. Set Host for the computer to 127.0.0.1:5900 and select the SSH server you created in #1. 

     

    Do this match what you've done?

  • Avatar
    Chris Olson

    I'm trying to do this exact same thing, is this process still supported?? I can't figure out how to manually create a connection in Jump Desktop?

Please sign in to leave a comment.