No Access to certain Mac system-level features

Comments

10 comments

  • Avatar
    I F

    Also fyi...if I disconnect Jump and reconnect with Mac Screen Sharing, everything works fine.

  • Avatar
    Jump Desktop Support

    Hi,

    Sorry you're having trouble. Which version of macOS are you running?

  • Avatar
    I F

    High Sierra 10.13.6

  • Avatar
    Jump Desktop Support

    I can confirm this is not a known issue. Do you have any third party apps that might be blocking input from Jump? Security apps etc? Can you also open up System Preferences -> Privacy -> Accessibility. Then click the + button and try adding Jump Desktop Connect into the list? 

     

  • Avatar
    I F

    Thanks. The closest thing I have to a security app etc is a VPN, but I turned that off for testing. Jump Desktop Connect and com.p5sys.jump.mac.viewer.web are already green-lit in the firewall. Again, everything works fine when using Mac Screen Sharing.

  • Avatar
    Jump Desktop Support

    Jump Desktop Connect needs to send input to the remote Mac. System Preferences -> Privacy -> Accessibility lists all the apps that are allowed to send input. Can you please add Jump Desktop Connect there? 

  • Avatar
    I F

    Here is an example of how it looks... https://i.imgur.com/p1CbP8u.mp4 

    The quick flashes in the menu happen each time I press and release the alt/opt key.

  • Avatar
    I F

    Ok, I added Jump to in Privacy / Accessibility. Still having the same problem. I'm also still not able to use two-finger horizontal swipes in apps like Safari. Maybe the problems are related?

  • Avatar
    AP

    I may be able to shed a little bit of light on this, as I have run into the same issue. From what I have been able to figure out, certain security functionalities simply cannot be performed remotely. Taking your above example, having to confirm a kernel extension or something via the "Security and Privacy" system preference, even if I connect via Apple's built-in screen sharing functionality I can click on the "Allow" button. In addition, I have a Mac Mini connected to a TV, and I have a remote mouse program install on my iPhone, and the server app on the Mac Mini - even using the remote mouse I can't click on the "Allow" button.

    My guess is that this isn't a bug or an oversight on Apple's part but a deliberate choice for security reasons. While annoying and frustrating, it does make some sense as it prevents a malicious entity that may have connected remotely from performing too much harm (i.e. installing a perpetual kernel extension that constantly reinstalls a virus after it's been removed).

  • Avatar
    I F

    You’re exactly right. It turns out that Apple implemented a security policy (starting in El Capitan I think) that doesn’t allow certain security features to be accessed from a remote desktop or synthetic mouse software.

    I’ve found a few workarounds that others have had success with...

     

    Using Script Editor

    -First, use Shift+Command+4 to determine the screen coordinates for the “Allow” button.

    -Then, in Script Editor, run: tell application "System Events" to click at {880, 511}

    *make sure to substitute with the proper coordinates

    *if you get an error like “Script Editor is not allowed assistive access.”, make sure Script Editor is enabled in System Preferences / Security & Privacy / Privacy / Accessibility

     

    Using Terminal

    -Run: osascript -e 'tell application "System Events" to click at {584, 819}'

    *again, insert the mouse coordinates you get from shift-cmd-4

     

    Using the Keyboard (Tab and Space Bar)

    -First, make sure you have “All controls” enabled; System Preferences / Keyboard / Shortcuts / Keyboard (All controls is at the bottom)

    -Then back in Security & Privacy, press the Tab key until the Allow button is highlighted, press the Space Bar to select it

    * the Security & Privacy page may need to be unlocked before Tab will work

     

    Using “Mouse Keys” (controlling the mouse using the keyboard number pad)

    -Enable Mouse Keys in System Preferences / Accessibility / Mouse & Trackpad

Please sign in to leave a comment.