Blurry screen on ipad

Answered

Comments

1 comment

  • Official comment
    Avatar
    Jump Desktop Support

    Hi Chris,

    At the moment Fluid Remote Desktop, on a Mac will only remote the non-retina resolution - which in your case is 1440x900 - this is purely for performance reasons (there are no limitations on the type of resolutions Fluid supports). At the moment this isn't configurable - this is what's causing the blurriness. I'm going to outline below how we're going to address this in our upcoming updates, in the meantime here are some workarounds that you can use today:

    1. Use an app like EasyRes (https://easyresapp.com) to manually switch the resolution over to a non-hdpi 4:3 aspect ratio resolution. This is going to make things much sharper.

    2. Use Jump's VNC protocol and Apple's ARD server to connect in 'Retina' quality mode: Open up 'Jump Desktop Connect' on your Mac and then click the settings icon on the top right. Then click 'Advanced' and enabled the 'VNC Server'. Also - open up 'System Preferences' -> Sharing and make sure 'Screen Sharing' is checked. You'll see a new, dark icon for your computer in Jump on your iPad - tap that to connect. Once connected, tap the tool icon on the top menu bar and set the Quality to 'Retina'. VNC is going to be slower than Fluid, though. 

    Either of the two above options should work. Here's what we're going to do to solve this in the near term and future:

    1. We're going to add automatic resolution switching to Jump so that when you connect, it adapts your desktop's resolution to something thats optional for the device you're connecting to.

    2. Quality settings for Fluid. At the moment Fluid already adapts the quality based on your connection bandwidth, however we're going to add a little more manual control and visibility into this (this will be implemented _after_ we add automatic resolution switching).

Please sign in to leave a comment.