Citrix X1 mouse not connecting to iPad Anymore

Comments

2 comments

  • Avatar
    Jump Desktop Support

    Hi,

    Sorry you're having trouble with the X1. Here are a couple of things to try:

    1. First make sure you unpair the X1 from all the devices you've paired it with. On iOS, open up the Settings app -> Bluetooth and then tap the blue arrow next to the Citrix X1 and then tap 'Forget this device'. If you've paired it with a non iOS device (like your Mac or Windows PC), make sure you unpair it there as well.

    2. Restart your iPad.

    3. Re-pair your mouse with the iPad and try to see if it works now.

    If the above doesn't help, try changing the battery on the mouse as well.

     

    0
    Comment actions Permalink
  • Avatar
    alessandro innocenti (Edited )

    Hi,

    thanks a lot for the prompt help!

    I have tried all the steps you have suggested, of course none of them did work :)
    I have also changed the mouse battery a couple of times (single AA cell) but that did not work either

    but I was able to pair the mouse with iPad by repeatedly pushing the button "connect" on its back, while executing the pairing procedure

    I had used that mouse for more than 1 month, that operation was NOT necessary until the last iPad update
    just keep pushing the "connect" button while the pairing is happening, otherwise you will get the iPad error message "it took too much time to communicate with the device... "
    hope this helps someone!

    0
    Comment actions Permalink

Please sign in to leave a comment.