iOS13 and Swiftpoint GT mouse issues

Comments

6 comments

  • Official comment
    Avatar
    Jump Desktop Support

    Hi, sorry you're having trouble with the mouse:

    Can you please make sure Jump has permission to access bluetooth: Open up Settings -> Jump. Make sure 'Bluetooth' is turned ON.

     

    Comment actions Permalink
  • Avatar
    Neff Markus (Edited )

    Same thing here, but with a Citrix X1.

    In Citrix Workspace app, my X1 still seems to work, so I assume a specific problem in the Jump Desktop application.

    Can Someone help us, please?

    1
    Comment actions Permalink
  • Avatar
    Gary Chun

    Hey Neff,

    I was able to get my Swiftpoint GT to work again but am not sure if this was what actually fixed it. I initially reverted back to iOS 12. I then updated to iOS 13. This time i didn’t turn on the Assistive Touch feature. The first time i installed iOS 13 i turned on Assistive Touch feature to use the mouse in iOS 13 and that seemed to mess up the controls in Jump Desktop. The second time i didn’t touch those settings and redid my entire Swiftpoint GT setup and it worked. I am hoping you won’t need to revert back to iOS 12 but i say give that a try. It’s a bit time consuming. 

     

    Or the other option is if Jump can do some sort of update.

    Thanks,

    0
    Comment actions Permalink
  • Avatar
    Neff Markus

    Hi Gary,

    thanks a lot for your proposal. For me that was not the root cause - support was able to help me and it turned out that during the update to iOS 13 the app must have lost permission to use bluetooth. After changing that in the app settings in the control panel, my mouse started working again.

    Best, Markus

    0
    Comment actions Permalink
  • Avatar
    Gary Chun

    Ok great! That makes more sense. Thank you for sharing that info!

    0
    Comment actions Permalink
  • Avatar
    Frank Pawlak (Edited )

    Still no connection with iPad 10.5 Pro; iPadOS 13.2.2 and Citrix Mouse X1 allthough bluetooth is enabled in jumpdesktop system setting :/

    Update:

    Problem solved!

    1. go to the iOS System bluetooth prefences. Make shure that bluetooth is on.

    2. Connect the Citrix x1 mouse to the iPad bz pressing the connect Button under the Citrix mouse. 

    3. open Jump desktop on the iPad and go to Preferences -> Mouses and gestures -> mouse -> Connect to mouse / status -> connected 

    0
    Comment actions Permalink

Please sign in to leave a comment.