Soundflower compatibility with Catalina

Comments

14 comments

  • Official comment
    Avatar
    Jump Desktop Support (Edited )

    Updated March 30 2002:

    We've added Blackhole audio support for Jump Desktop. We're going to be rolling out the automatic update soon, however, if you want to update manually to Jump Desktop Connect with Blackhole support open up Jump Desktop Connect -> Settings -> Updates -> CHECK Beta updates and click 'Check for updates'.

    Old response:

    Hi,

     

    We've tested Soundflower with Catalina and it works great for us. What kind of problem are you seeing?

     

    Also - thanks for the link to BlackHole. We'll check it out and see if we can add support for that too.

    Comment actions Permalink
  • Avatar
    J.

    I managed to install the driver and the sound control panel shows the Soundflower option. When using the iPad JumpDesktop client connecting to the Mac, there's no sound from iPad. I've checked the settings and it has audio on.

    Is there any specific steps I'm missing?

    1
    Comment actions Permalink
  • Avatar
    Jump Desktop Support

    Here are a couple of things I can think of:

    1. Make sure you're running Jump Desktop 9.1.2 for iOS on your iPad (we're rolling this out right now but you can manually update by opening up the App Store on your iPad and hitting 'Update' for Jump Desktop).

    2. On the Mac, open up Jump Desktop Connect and make sure you're on 6.3.14 or later (Jump Desktop Connect -> Settings icon -> Diagnostics).

    Can you please update me on how it goes?

    0
    Comment actions Permalink
  • Avatar
    J.

    Found the issue, I was on the TestFlight program.

    The iPad beta app version was 9.2.0 - when connecting to the Mac - Mac didn't show "Allow Jump Desktop Microphone Access".

    It might be useful to provide a guide about how to install the Soundflower driver/configuration/app permission. It was really confusing at the beginning as there are multiple Soundflower versions available to install from an under-maintained link. 

    Thank you for providing diagnoses support.

    1
    Comment actions Permalink
  • Avatar
    T

    Hi, I'm having the same issues like J.

    1.) I'm unable to install Soundflower on my Mac running Catalina. I used Soundflower before, but with Catalina it wasn't supported anymore. I downloaded                               Soundflower-2.0b2.dmg              but installation fails (no reason given).

    (I was able to install BlackHole though)

    2.) I connect from another Mac, iPhone and iPad (all with latest Jump Desktop app) to my Mac that I want to stream audio from. There was never any popup asking for microphone access and there is no entry from Jump Desktop in Settings/Privacy/Microphone.

    @ J. How did you install Soundflower? Can you provide a link, please?

    @Support Any ideas how to fix this?

    0
    Comment actions Permalink
  • Avatar
    J. (Edited )

    The first attempt of Soundflower will fail. You need to open General Settings -> Security & Privacy -> General (tab). There should be a button to allow Soundflower to be installed. Then try to install Soundflower again.

     

    After a successful installation, two soundflower option should appear in the sound options menu. When JumpDesktop connects to the Mac, it will automatically use the right sound option. You don't need to switch settings manually.

    1
    Comment actions Permalink
  • Avatar
    T

    Hi J., thank you very much!

    That solved it for me!

    BR

    T

    1
    Comment actions Permalink
  • Avatar
    J.

    np, i'm glad it helped. Also thanks for the JD team release this wonderful feature!

    0
    Comment actions Permalink
  • Avatar
    Graham Berks

    Any news on BlackHole support ?

    Thanks

    0
    Comment actions Permalink
  • Avatar
    Graham Berks

    I'm getting sound dropouts using Soundflower on Catalina

    0
    Comment actions Permalink
  • Avatar
    Jump Desktop Support

    @Graham - we'd added Blackhole audio support. We're going to be rolling up the automatic update soon, however, if you want, update manually to Jump Desktop Connect with Blackhole support open up Jump Desktop Connect -> Settings -> Updates -> CHECK Beta updates and click 'Check for updates'.

    0
    Comment actions Permalink
  • Avatar
    Graham Berks

    Ah great thanks !

     

    Did you notice anything difference in quality / performance etc ?

     

    Will give it a spin.

    0
    Comment actions Permalink
  • Avatar
    Jump Desktop Support

    @Graham - definitely noticed lower latency with Blackhole.

    0
    Comment actions Permalink
  • Avatar
    Graham Berks

    Seems to work well for my limited testing ! Thanks

    0
    Comment actions Permalink

Please sign in to leave a comment.