Unable to get Apple Pencil to Select text as before

Comments

2 comments

  • Official comment
    Avatar
    Jump Desktop Support (Edited )

    Hi Eric,

    You probably just updated to Jump Desktop 9.0 for iOS, where among other things, we changed the way Apple Pencil is handled on machines that support Windows touch. But don't worry - you can revert back to the old behavior if you want.

    How to revert Apple Pencil behavior to pre-9.0:

    First off, if you simply want to revert back to the old Apple Pencil behavior before 9.0: Open up Jump Desktop -> Tap the settings icon on the top left -> Mouse & Gestures -> TURN OFF 'Smart Touch Gestures' That's it - the Apple Pencil will now work the way you're used to it working before 9.0.

    How has Apple Pencil handling changed in 9.0:

    In previous releases, Jump directly converted Apple Pencil input to left mouse clicks or right clicks on the remote computer. It still does this now, however, if you're connecting to Windows 8.1 or later over RDP, it will now convert Apple Pencil input to 'touch' input on the remote computer. To the remote computer, it will seem as if you're actually using a single 'finger' (not a mouse) to interact with it. There are quite a few advantages to this in our opinion: The biggest win is easier scrolling: You can grab any part of the remote app's content by tapping your Apple Pencil and 'throw' it to scroll content vs the old way of tapping at the scroll bar to scroll. Left click / right click functionality remains the same but left clicks are generally 'smarter' because they depend on which area of the remote window you're interacting with. For example, if you tap a remote window's title bar, you'll be able to drag it immediate.

    How do I select text using the new Apple Pencil behavior:

    Like you would when you're using your finger on the remote machine: Double tap the text and you'll see handle bars around the text. Drag the handle bars to select the text. Remember: You can always revert back to the old behavior (see above).

    Finally the word "Home" super imposed on the middle of the screen:

    That's probably your connection's name. In iOS 13 and later Jump now supports opening multiple simultaneous connections - i.e you can be connected to multiple computers at the same time in different windows on the iPad. When you launch a connection or switch to it via multitasking, Jump briefly shows you the connection's name you just switched to. It's harmless and it's just there to help you know which connection you're on because it's very easy to get confused if you have more than a couple of connections open. Again - it's harmless and doesn't participate in interactions (i.e. you an still touch on elements underneath).

    Hope this helps.

    Comment actions Permalink
  • Avatar
    Eric Valencia

    Thank you for responding.  I solved this by disabling Smart Touch Gestures.  I did this by clicking Settings (Gear icon) > Mouse & Gestures > uncheck Smart Touch Gestures. Always keep Smart Touch Gestures unchecked when using Apple Pencil, otherwise, it causes the pencil to grab and drag instead of selecting text!

    0
    Comment actions Permalink

Please sign in to leave a comment.