Mac to Mac shortcuts

Comments

7 comments

  • Official comment
    Avatar
    Jump Desktop Support

    Hi,

    The functionality is available: Open up Jump Desktop -> Preferences -> Keyboard. & Mouse -> When connecting to ‘Mac’. Here you can add / edit your mappings as well as disable any existing keyboard shortcuts that Jump handles for it’s own menus.

    Comment actions Permalink
  • Avatar
    Ljalmanzar

    I have already tried this. I entered the shortcut to map to itself. I then tried it with the jump shortcuts enabled and disabled. Neither worked.

    0
    Comment actions Permalink
  • Avatar
    Jump Desktop Support (Edited )

    Can you try installing this on the Mac you are connecting TO: https://apps.apple.com/ca/app/key-codes/id414568915?mt=12 . Then try connecting to it from your Mac and see what is being received on the remote Mac? Wondering if Jump is sending the right shortcuts.

    0
    Comment actions Permalink
  • Avatar
    Ljalmanzar

    Alright, so the first four in this screenshot are with the custom modifier enabled. And the second with it disabled. Both seem the same. Looks like something might be weird with the arrow.

    Another note that might help.. Even If i have jump  in a windowed mode, with the mouse cursor locked (so i know it is focused inside the jump window), the shortcut still works on the local machine snapping the jump window to the right.

    0
    Comment actions Permalink
  • Avatar
    Jump Desktop Support

    Thank you for trying that. Looks like it's not getting the last right arrow key.

     

    > the shortcut still works on the local machine snapping the jump window to the right.

    Can you click Remote and then make sure 'macOS Shortcuts' is CHECKED? Then try it one more time.

    0
    Comment actions Permalink
  • Avatar
    Ljalmanzar (Edited )

    Yea, i can confirm that I have been trying it both with and without the option checked the whole time.

    so i tested around with that keycodes app.. looks like other combinations of modifier keys with an arrow are getting sent correctly. It is just something about option+cmd+arrow.. then the arrow is not being sent. 

    i suppose i could just change the shortcut i use. i do think the reason i chose opt+cmd was because it overlapped with the least amount of other shortcuts.

    Thinking about it, it has to be something with the fact that I am using an app called "BetterTouchTool" to set the keyboard shortcut. I completely disabled that in the local computer and now the full keystroke is being seen on the remote computer. But the shortcut is still not being trigger by BetterTouchTool on the remote computer. This is for RDP and i'm using fluid, but could be related. https://community.folivora.ai/t/shortcut-sending-not-working-with-microsoft-remote-desktop-10/9256

    0
    Comment actions Permalink
  • Avatar
    Ljalmanzar

    Can you guys confirm what that post says?

    Is this a lost cause that I should just try to stop making work? Which really sucks.. 

    0
    Comment actions Permalink

Please sign in to leave a comment.